В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
DasyaSay
DasyaSay
01.05.2022 17:34 •  Информатика

Написать программу на языке с++. дано натурально число а в десятичной системе счисления. если все цифры числа а различные, то вывести на экран сообщение "да", иначе - сообщение "нет".

Показать ответ
Ответ:
stentani97
stentani97
04.10.2020 11:13
#include <iostream>
using namespace std;

int main()
{
    int a;
    int k[9];
    bool f = true;
    cout << "a = ", cin >> a, cout << "\n";
    for (int i=0; i<10; i++) k[i]=0;
    while (a>0){
    k[a % 10]++;
    a = a / 10;
    }
    for (int i=0; i<10; i++){
    if (k[i]>1) f = false;
    }
    if (f) cout << "Да" << "\n";
    else cout << "Нет" << "\n";
    return 0;
}

Пример:
a = 12523
Нет
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота