Написать программу на языке с++ или java или pascal или python.
вводятся два символа некоторого алфавита, вероятности их появления и составления из них произвольная последовательность, длина которой кратна двум. программа выполняет следующие функции:
а)проверка и нормирование вероятностей появления символов;
б)проверка длины введенной последовательности на четность и отбрасывание последнего символа в случае нарушения четности;
в)генерация всех возможных различных двухсимвольных комбинаций и их экономное двоичное кодирование;
г)разбиение введенной последовательности на двухсимвольные комбинации, замена их на сгенерированные двоичные коды и формирование результирующей последовательности путем сцепления полученных двоичных кодов;
г)вывод результирующей последовательности на экран.
Лабораторная работа
ТЕМА: Дизайн и создание презентаций лекционного материала, научных отчетов и т. Д.
ЗАДАЧА: Создайте презентацию в формате PowerPoint по теме «Новости ИКТ», состоящую из 10 или более слайдов. Используйте анимацию, ссылки, фильмы, звук.
Как создать презентацию PowerPoint
Сегодня ни один отчет не обходится без презентации.
Такое представление информации подробно представить все необходимые графики и расчеты.
Далее подробно рассмотрим, как создать презентацию в PowerPoint.
Объяснение:
тебе перевод нужен ? а то только это тебе могу сделать а слайд тебе не как не скину
var c: string;
begin
writeln('Введите 1 число.');
readln(a);
writeln('Введите 2 число.');
readln(b);
writeln('Знак операции.');
readln(c);
if c='*' then writeln(a*b);
if c='/' then writeln(a/b);
if c='-' then writeln(a-b);
if c='+' then writeln(a+b);
end.
2 ЗАДАЧА
var a, b: real;
begin
writeln('Зарабаток Пети:');
readln(a);
writeln('Зарабаток Петрова:');
readln(b);
if a>b then writeln('Петя заработал больше Петрова.')
else if a=b then writeln('Петров и Петя заработали одинаково.')
else
writeln('Петров заработал больше Пети.');
writeln('Среднее: ', (a+b)/2);
end.