В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу на языке с++, которая вычисляет произведение отрицательных чисел среди четырех заданных. после чего сообщает - является ли полученное произведение отрицательным или положительным

Показать ответ
Ответ:
yarmen021
yarmen021
10.10.2020 08:41

#include <iostream>

using namespace std;

int main()

{

 int a[4];

 int i, p;

 setlocale(LC_ALL, "russian");

 cout << "Введите четыре числа: ";

 for (i = 0; i < 4; i++) {

   cin >> a[i];

 }

 p = 1;

 for (i = 0; i < 4; i++) {

   p *= a[i];

 }

 if (p > 0)

   cout << "\nПроизведение положительно";

 else if (p < 0)

   cout << "\nПроизведение отрицательно";

 else

   cout << "\nПроизведение равно 0";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота