В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Huliganka3009
Huliganka3009
24.01.2020 03:08 •  Информатика

Написать программу на языке С (массивы)
1.Посчитать количество элементов массива, меньших 45
2.Найти среднее арифметическое элементов массива, меньших

Показать ответ
Ответ:
lazyseal1488
lazyseal1488
06.09.2020 22:21

//Братишка, я тебе опять С++ принёс

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int n;

   cout<<"Enter size of array\n";

   cin>>n;

   int *arr = new int;

   for(int i = 0;i<n;i++){

       cin>>arr[i];

   }

   int counter_of_less_fortyfive = 0;

   vector<int>seventyeight;

   for(int i = 0;i<n;i++){

       if(arr[i]<45){

           counter_of_less_fortyfive++;

       }

       if(arr[i]<78){

           seventyeight.push_back(arr[i]);

       }

   }

   int summ_seventyeight = 0;

   for(auto &i:seventyeight){

       summ_seventyeight+=i;

   }

   float average_seventyeight = summ_seventyeight / seventyeight.size();

   cout<<"Quantity of elements wich less then 45 is "<<counter_of_less_fortyfive<<endl;

   cout<<"Average of elements wich less 78 is "<<average_seventyeight;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота