В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ZakAnyta
ZakAnyta
10.07.2020 12:14 •  Информатика

Написать программу на языке с++: сформировать случайным образом целочисленную матрицу n*n. сформировать два одномерных массива а и в: в массив а записать элементы матрицы, расположенные на главной диагонали и ниже неё, в массив в - элементы, лежащие на побочной диагонали и ниже неё

Показать ответ
Ответ:
ValeriyaGerner
ValeriyaGerner
06.10.2020 13:15
#include <iostream>
#include <iomanip>
#include <ctime>

int main()
{
    setlocale(LC_ALL, "RUSSIAN");
    const int N = 5;
    int matrix[N][N];
    int A[(N*N) / 2], B[(N*N)/2];
    int k = 0;
    srand(time(NULL));
    for (int i = 0; i < N; i++)
    {
        std::cout << std::endl;
        for (int j = 0; j < N; j++)
        {
            matrix[i][j] = rand() % 100;
            std::cout << std::setw(3) <<  matrix[i][j] << " ";
        }
    }
    for (int i = 0; i < N; i++)
        for (int j = 0; j < N; j++)
            if (i >= j)
            {
                A[k] = matrix[i][j];
                k++;
            }
    std::cout << std::endl;
    std::cout << "Массив, содержащий элементы, лежащие на главной диагонали и ниже ее:" << std::endl;
    for (int i = 0; i < k; i++)
        std::cout << A[i] << " ";
    k = 0;
    std::cout << std::endl;
    for(int i=0; i<N; i++)
        for (int j = N - i-1; j < N; j++)
        {
            B[k] = matrix[i][j];
            k++;
        }
    std::cout << "Массив, содержащий элементы, лежащие на побочной диагонали и ниже ее:" << std::endl;
    for (int i = 0; i < k; i++)
        std::cout << B[i] << " ";
    std::cout << std::endl;
    system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота