В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ANNAAFANASYEVA1
ANNAAFANASYEVA1
12.06.2020 19:10 •  Информатика

Написать программу на языке с++(со всеми объяснениями )
написать функцию, которая возвращает 1, если число, полученное в качестве аргумента, является простым, и ноль – в противном случае.​

Показать ответ
Ответ:
basarbakhtiar
basarbakhtiar
10.10.2020 12:35

#include <iostream>

using namespace std;

int F(int n)   // сама функция

{

   if(n<2) return 0; // простые числа начинаются от 2

   if(n==3) return 1; // число 3 - простое

   bool found = (n % 2 == 0); // если число четное, делитель найден

   int p = 3;

   while((!found) && (p*p <= n)) // цикл поиска делителя

   {

       found = (n % p == 0); // найден ли делитель

       p+=2; // следующий делитель для проверки

   }

   return !found;

}

int main()  // тестовая программа

{

   int k;

   cin >> k;   // ввод числа

   cout << "Result: " << F(k); // тестируем функцию

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота