В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
поняття
поняття
21.02.2023 00:49 •  Информатика

Написать программу на языке С#. Тема: switch, case, break, goto Дано арифметическое выражение, например: 2+3= ... Вместо точек надо поставить сумму

Показать ответ
Ответ:
sotlen61Ang
sotlen61Ang
12.07.2021 00:09

var

 n, i: Integer;

 s: string;

 isu: Boolean;

begin

 Write ('Введите число: ');

 Read (n);

 if (n >= 1000) and (n <= 9999) then

   WriteLn ('Это число четырехзначное')

 else

   WriteLn ('Это число не четырехзначное');

 s := IntToStr (n);

 isu := True;

 for i := 1 to Length (s) - 1 do begin

   if s [i] <= s [i + 1] then begin

     isu := False;

     Break;

   end;

 end;

 WriteLn;

 if Isu then

   WriteLn ('Цифры расположены в порядке убывания')

 else

   WriteLn ('Цифры НЕ расположены в порядке убывания');

end.

0,0(0 оценок)
Ответ:
iPHONee12
iPHONee12
21.05.2022 17:13

var

 A, Ap, Ao: array [1..14] of Integer;

 i, c, cp, co: Integer;

 s: Real;

begin

 Randomize;

 WriteLn ('Mассив:');

 for i := Low (A) to High (A) do begin

   A [i] := Random (201) - 100;

   Write (A [i], ' ');

 end;

 cp := 0;

 co := 0;

 for i := Low (A) to High (A) do begin

   if A [i] > 0 then begin

     cp := cp + 1;

     Ap [cp] := A [i];

   end else begin

     co := co + 1;

     Ao [co] := A [i];

   end;

 end;

 c := Low (A);

 for i := 1 to cp do begin

   A [c] := Ap [i];

   c := c + 1;

 end;

 for i := 1 to co do begin

   A [c] := Ao [i];

   c := c + 1;

 end;

 WriteLn;

 WriteLn ('Результат: ');

 for i := Low (A) to High (A) do begin

   Write (A [i], ' ');

 end;

 WriteLn;

 WriteLn ('Количество положительных элементов массива = ', cp);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота