В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
daniilbabics
daniilbabics
24.07.2020 18:36 •  Информатика

Написать программу на языке с. x+t при x^2+ sint> 0,1 y={ 2x+t^2 при x^2+ sint< 0,1 x-t при x^2+ sint= 0,1

Показать ответ
Ответ:
saparhanaruzhan
saparhanaruzhan
08.10.2020 02:18
#include <iostream>
#include <cmath>
using namespace std;
 
int main()
{
int x = 0;
int t = 0;
int y = 0;
cin >> x >> t;
if (pow(x, 2) + sin(t) > 0.1) {
y = x + t;
} else if (pow(x, 2) + sin(t) < 0.1) {
y = 2 * x + pow(t, 2);
} else if (pow(x, 2) + sin(t) == 0.1) {
y = x - t;
}
cout << y;
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота