В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
androp4ik1
androp4ik1
12.05.2021 21:06 •  Информатика

Написать программу (на языке Си), которая находит все двузначные числа, для которых сумма цифр входящих в число плюс квадрат суммы этих же цифр
равна самому числу.

Показать ответ
Ответ:
anyamaleva97
anyamaleva97
05.03.2021 17:14

#include <stdio.h>

#include <math.h>

int main(){

   for (int i = 10; i< 100;i++)    

       if ((pow(i%10+i/10,2) + i%10 + i/10) == i)

           printf("%d\n",i);

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота