В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
vika2082
vika2082
28.03.2020 18:23 •  Информатика

Написать программу на языке си++ вычислить сумму ряда до 20 члена s=)*(k! +1)*x^k)/3^k

Показать ответ
Ответ:
MissEvaStar
MissEvaStar
03.10.2020 05:07
Исходя из вашего запроса:
без отрицания k
#include <iostream>
using namespace std;
int main()
{   
int a,k,s,x;
 for (k=0; k<20; k++)
{       
s +=((-1)*(k+1)*x^k)/3^k;   
}   
cout << s << endl;   
system("pause"); // или _getch();
return 0;
}

с отрицанием k
#include <iostream>
using namespace std;
int main()
{   
int a,k,s,x;   
for (k=0; k<20; k++)   
{       
s +=((-1)*(k+1)*x^k)/3^k;   
}   
cout << s << endl;   
system("pause"); // èëè _getch();   
return 0;
}
и формулируйте вопрос корректнее. 
в обоих решениях k=0 изначально
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота