Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Mashavyd
05.07.2022 15:03 •
Информатика
Написать программу, на языке си, выводящую все чётные числа на отрезке от a до b. в этой нельзя использовать инструкцию if.
Показать ответ
Ответ:
Dashalu45
09.09.2020 15:27
#include <stdio.h>
#include <conio.h>
int main (int argc, char *argv[])
{
int A, B;
printf("A = ");scanf("%d", &A);
printf("B = ");scanf("%d", &B);
A = A + A % 2;
B = B - B % 2;
for (A = A; A<=B; A = A+2)
printf("%d ", A);
getch();
}
0,0
(0 оценок)
Популярные вопросы: Информатика
ALIONA2020
02.02.2021 02:59
1. Выберите верную схему передачи информации А) источник информации àкодирующее устройство àканал связи à декодирующее устройство àприёмник информации Б) источник информации...
Скрррррооо
29.10.2021 12:27
Опишите сжатия текстовой и графической информации...
пахан50
16.03.2020 00:56
Описать процедуру вычисления количества отрицательных чисел в массиве w и n элементов...
123FoxYouTube123
21.09.2021 14:05
Будь ласка,напешіть практичну роботу, мне очень потрібно,кто понімает,даю много....
plimita134
12.05.2022 02:03
Какой может быть максимальная мощность алфавита, если количество двоичных разрядов при кодировании равно: 5 разрядов3 разряда4 разряда6 разрядов2 разряда...
Маша270902
02.05.2020 13:39
К какому порту подключается инфракрасный датчик скажите ...
yubloh
04.09.2021 02:00
В матрице K(7, 7) найти и записать в одномерный массив А нечетные элементы среди элементов, сумма индексов которых – четная. Переставить элементы в полученном массиве по правилу:...
Ди1501
26.10.2021 05:35
нужно составить программы для Python решая задачи 2. Даны три различных числа A, B, C. Выведите на экран значение среднего из них. 4. Даны три числа, два из которых одинаковые....
syslik7773
13.01.2021 06:34
Скажите задание 2а) будет какой ответ? А то два разных получается...
kalmykov24
23.01.2021 00:19
1. Что такое компьютер? 2. Что такое компьютерная программа? 3. Что такое системный блок? (+ перечислить, что входит в состав) 4. Что такое средства манипуляции? (+перечислить)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <conio.h>
int main (int argc, char *argv[])
{
int A, B;
printf("A = ");scanf("%d", &A);
printf("B = ");scanf("%d", &B);
A = A + A % 2;
B = B - B % 2;
for (A = A; A<=B; A = A+2)
printf("%d ", A);
getch();
}