В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
leski
leski
26.05.2022 13:53 •  Информатика

Написать программу на языке С

Напишите функцию заполнения массива 10-ю случайными числами в диапазоне от -40 до 40, функцию вывода элементов массива.

Показать ответ
Ответ:
Daniilgrishin333333
Daniilgrishin333333
15.10.2020 12:52

//Братишка, я тебе С++ принёс

#include <iostream>

#include <ctime>

#include <cstdlib>

using namespace std;

void fill(int arr[10]){

   srand(time(NULL));

   for(int i = 0;i<10;i++){

       arr[i] = rand() % 81 + -40;

   }

}

void output(int arr[10]){

   for(int i = 0;i<10;i++){

       cout<<arr[i]<<endl;

   }

}

int main()

{

   int arr[10];

   fill(arr);

   output(arr);

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота