В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
zulyakhalilova
zulyakhalilova
07.12.2020 17:05 •  Информатика

Написать программу находящую сумму всех трехзначных чисел, в записи которых есть четные цифры

Показать ответ
Ответ:
anciferovalex
anciferovalex
24.05.2020 15:07

var a,b,c,d,j:integer;
begin
j:=0;
for a:=100 to 112 do
begin
b:=a div 10;
d:=a mod 10;
c:=a-(100*b)-d;
if (a div 2=a/2) or (b div 2=b/2) or (c div 2=c/2) then j:=j+1;
end;
writeln(j);
end.

это для pascalABC 

 
0,0(0 оценок)
Ответ:
KaterinaFadeeva
KaterinaFadeeva
24.05.2020 15:07

Program n1;
Uses CRT;
Var a,b,c,s,i: integer;
begin
ClrScr;
For i:=100 to 999 do
begin
a:=i div 100;
b:=i mod 100 div 10;
c:=i mod 10;
If (a mod 2=0)or(b mod 2=0)or(c mod 2=0) then s:=s+i;
end;
writeln('summa ravna ',s);
readln
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота