В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
MariaWoLF2006
MariaWoLF2006
10.03.2020 22:19 •  Информатика

Написать программу нахождения значения выражения. результат вывести с двумя знаками после запятой.

Показать ответ
Ответ:
corvet42
corvet42
02.06.2022 14:22
Var a,k1,k2,s:integer;
begin
writeln('Вводите целые числа. Конец ввода - 0');
k1:=0;
k2:=0;
s:=0;
readln(a);
while a<>0 do
 begin
 if (a mod 2 = 0)and(a<0) then k1:=k1+1;
 if a mod 2 <> 0 then begin k2:=k2+1; s:=s+a; end;
 readln(a);
 end;
writeln('количество четных отрицательных чисел = ',k1);
if k2>0
 then writeln('среднее арифметическое нечётных чисел = ',s/k2)
 else writeln('в последовательности нет нечётных чисел');
end.

Пример:
Вводите целые числа. Конец ввода - 0
18
-45
10
-62
70
0
количество четных отрицательных чисел = 1
среднее арифметическое нечётных чисел = -45
0,0(0 оценок)
Ответ:
тьпнли
тьпнли
02.06.2022 14:22
Var a,k1,k2,s:integer;
begin
writeln('Вводите целые числа. Конец ввода - 0');
k1:=0;
k2:=0;
s:=0;
readln(a);
while a<>0 do
 begin
 if (a mod 2 = 0)and(a<0) then k1:=k1+1;
 if a mod 2 <> 0 then begin k2:=k2+1; s:=s+a; end;
 readln(a);
 end;
writeln('количество четных отрицательных чисел = ',k1);
if k2>0
 then writeln('среднее арифметическое нечётных чисел = ',s/k2)
 else writeln('в последовательности нет нечётных чисел');
end.

Пример:
Вводите целые числа. Конец ввода - 0
18
-45
10
-62
70
0
количество четных отрицательных чисел = 1
среднее арифметическое нечётных чисел = -45
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота