В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
KONERtm
KONERtm
11.04.2021 01:15 •  Информатика

написать программу
Напишите программу, которая определяет величину самой большой зарплаты
сотрудников и выводит количество сотрудников с этой максимальной зарплатой.
Формат входных данных:
В первой строке входного файла записано число N, о второй строке – через пробел N
чисел, обозначающих зарплату сотрудников в рублях (зарплата сотрудника не больше
105 рублей)
Формат выходных данных:
В выходном файле должно находиться одно число - количество сотрудников с
максимальной зарплатой.

Показать ответ
Ответ:
Anastasya156
Anastasya156
24.12.2022 16:58
Началось все с самого простого калькулятора, который мог переводить из десятичной системы счисления в двоичную, восьмиричную и шестнадцатеричную. Потом один из пользователей запросил возможность переводить число из десятичной системы счисления в схему с любым другим основанием. Так появился калькулятор в котором можно было указывать основание системы счисления в которую надо перевести десятичное число. Вводится число FF, вводится основание системы счисления этого числа - 16. Потом, основание системы счисления, в которую надо переобразовать , это число- 10. Получается результат 255 в десятичной системе счисления.
0,0(0 оценок)
Ответ:
akulkaeva78
akulkaeva78
27.05.2021 07:46

#include <iostream>

using namespace std;

int main() {

setlocale(LC_ALL, "");

int N = 10;

int max = -9999999;

int sum = 0;

int choise = 0;

int arr[N] = {0};

cout << "Введите 10 значений: ";

for(int i = 0; i<N; ++i) {

cin >> arr[i];

}

cout << "Введите действие (1 - +, 2 - макс. значение, 3 - колво отр. значений)";

cin >> choise;

if(choise==1) {

for(int i = 0; i<N; ++i) {

sum+=arr[i];

}

cout << endl << "Сумма: " << sum;

}

if(choise==2) {

for(int i = 0; i<N; ++i) {

if(arr[i]>max) {

max = arr[i];

}

}

 cout << endl << "Макс. знач: " << max;

}

if(choise==3) {

 for(int i = 0; i<N; ++i) {

   if(arr[i]<0) {

     ++sum;

   }

 }

 cout << "Колво отр. знач: " << sum;

}

 if(choise!=1&&choise!=2&&choise!=3) {

   cout << "Введите корректное значение.";

 }

 return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота