В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
FannyPanda
FannyPanda
30.01.2021 03:17 •  Информатика

написать программу . Найти максимальный элемент , встречающийся в матрице более одного раза . С++​

Показать ответ
Ответ:
SiRuES
SiRuES
13.02.2023 04:58
Когда вы запускаете Word, он автоматически предлагает вам чистый документ, в который довольно удобно вводить текст. Значит, логично будет предположить, что после запуска Word вы этим и займетесь. Если вы в Word редактируете определенный документ и вам понадобилось открыть новый (например, вы пишете письмо другу, но вдруг вспомнили, что необходимо ответить на запрос), то выполните следующие действия. Выберите команду Файл › Создать. На экране появится область задач Создание документа. На ней представлено несколько вариантов создания нового документа. Выберите опцию создания нового документа.Щелкните на ссылке Новый документ. Область задач будет скрыта, а на экране появится пустая страница нового документа.Если вы очень спешите, новый документ можно также создать, щелкнув на кнопке Создать . Таким образом, вам не потребуется искать необходимый вариант в области задач. Да и сама область задач при этом на экране не отображается. В главе 10 подробно рассказывается о том, как организовать в Word одновременную работу с несколькими документами.Еще один приступить к работе заключается в следующем: откройте документ на диске. (Дополнительную информацию по этому вопросу можно найти в главе 8.) Открытый документ появится в окне. Можно работать!
0,0(0 оценок)
Ответ:
flora21345
flora21345
06.08.2022 15:45
Var m : array[0..6] of Integer;
  i,k,N : Integer;
Begin
  For i:=0 to 6 do m[i]:=0;
  Readln(N);
  k:=6;
  While N>0 do
  Begin
    If N>=Power(2,k) then
    Begin
      N:=N-Trunc(Power(2,k));
      Inc(m[k]);
    end else Dec(k);
  end;
  For i:=0 to 6 do Writeln(Power(2,i),'  ',m[i],' шт.');
end.

Еще вариант:
Const
  NN = 7;
  money : array[1..7] of Integer = (1,2,4,8,16,32,64);
Var m : array[1..NN] of Integer;
  i,k,N : Integer;
Begin
  For i:=1 to NN do m[i]:=0;
  Readln(N);
  k:=NN;
  While N>0 do
  Begin
    If N>=money[k] then
    Begin
      N:=N-money[k];
      Inc(m[k]);
    end else Dec(k);
  end;
  For i:=1 to NN do Writeln(money[i],'  ',m[i],' шт.');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота