Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Nastasia8879
11.10.2022 21:40 •
Информатика
Написать программу! найти сумму чётных чисел в интервале от а до в ( а и в - натуральные числа, а< в).
Показать ответ
Ответ:
Елизаветакотовамимар
02.10.2020 11:50
uses Crt;
var a, b, temp, i, S:integer;
begin
ClrScr;
Write (' a = '); ReadLn(a);
Write (' b = '); ReadLn(b);
S:=0;
i:=a;
while i<=b do
begin
if (i mod 2 = 0) then S:=S+i;
i:=i+1;
end;
WriteLn(' S = ', S);
ReadLn;
end.
0,0
(0 оценок)
Ответ:
vlad041204
02.10.2020 11:50
Var a,b,i,sum: integer;
begin
write ('Введите границы интервала: ');
read (a,b);
for i:= a to b do
if i mod 2 = 0 then sum:=sum + i;
writeln ('Сумма четных чисел в интервале от А до Б = ',sum);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
дюха4004
05.11.2021 02:11
Компьютерлік вирус деген не...
1ПИНЧЕР1
11.03.2020 13:50
Установите соответствие между антивирусными программами и их Количество соединений:3avsat esetКайсперский СОР...
54женек4
22.05.2022 03:35
Хотя бы что то через программу pascal: 1)запись заданного длинного целого числа имеет нечетное количество цифр. вывести на экран среднюю цифру. 2)написать функцию определяющую...
drart77
13.04.2021 11:21
A) если к трём прибавить четыре, потом умножить все на четыре и разделить на разность восьми и шест, то в реултате получится четырнадцать. b) разность двацати семи сотых...
Софья909
13.04.2021 11:21
1.в алфавите 64символа.каков информационный вес одного символа? 2.учебник набран с пк.в учебнике 259стр.,на каждой странице-70строк в каждой строке по 90символов.сколько...
YakovlevaJulia2004
13.04.2021 11:21
Иколя играют в следующию игру: петя задумывает правило преобразования текстовой информации.коля может предлогать пете любые тексты и узнавать результаты преобразования....
aliha001
24.04.2020 10:58
Перечислите, 3 действия, которые следует выполнить, чтобы не нарушать авторское право ...
даша3644
04.08.2020 19:16
Выбери верный адрес ячейки. - E 8 -29 -VVV...
SofStrelets
21.08.2022 12:50
Создать массив из 12 элементов и заполнить его случайными целыми числами,принадлежащими промежутку [-4; 10)...
nastgoliakova
21.08.2022 12:50
Сообщение занимает 50 страниц по 20 строк, в каждой строке записано по 55 символов. сколько символов в сообщении?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var a, b, temp, i, S:integer;
begin
ClrScr;
Write (' a = '); ReadLn(a);
Write (' b = '); ReadLn(b);
S:=0;
i:=a;
while i<=b do
begin
if (i mod 2 = 0) then S:=S+i;
i:=i+1;
end;
WriteLn(' S = ', S);
ReadLn;
end.
begin
write ('Введите границы интервала: ');
read (a,b);
for i:= a to b do
if i mod 2 = 0 then sum:=sum + i;
writeln ('Сумма четных чисел в интервале от А до Б = ',sum);
end.