В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Слава200109
Слава200109
22.10.2020 10:00 •  Информатика

Написать программу определения заданной характеристики последовательности чисел с1,, для
количества чисел равных с1. (в compmodel)

Показать ответ
Ответ:
pron1983
pron1983
07.01.2023 00:12
Вот на шарпе.
 Console.WriteLine("s1=");           
string s1=Console.ReadLine();           
int k=1;int max=0;           
for (int i = 1; i < s1.Length-1; i++)            
{               
if (s1[i-1] == s1[i])               
{                   
k++;               
}               
else                
{                   
 if (k > max)                  
  {                       
max = k;                       
k = 1;                   
 }               
 }         
  }           
 Console.WriteLine(max);           
 Console.ReadKey();
0,0(0 оценок)
Ответ:
Jullia123123
Jullia123123
19.11.2020 19:48
Профессиями? Ну, в руках знающих людей компьютер может быть инструментом для звукорежиссеров, специалистов по спец. эффектам в видео, системных администраторов.
Microsoft Office для решения офисных задач (электронные таблицы для автоматизированных вычислений, презенетации для, собственно, проведения презентаций, и так далее), Paint для рисования, Steam для развлечений.
Информатика - наука о инф... короче, с у Goоgle, он ответил, что надо на Википeдии посмотреть статью "Информатика".
Какое именно? Думаю, процессор можно назвать таковым.
Жёсткий диск, твёрдотельный диск (SSD), USB-флешки (Pendrive), лазерные диски форматов CD, DVD, HD-DVD, Blu-Ray. Сделаю вид, что помню, что такое дискеты, но на самом деле постараюсь забыть, что это - почти полторы минуты копировать один мегабайт.
Таак... Блок питания, материнская плата, процессор, оперативная память, жёсткий или твёрдотельный диск, монитор, мышь, клавиатура, видеокарта, звуковая карта (обычно она встроена в материнскую плату, но есть и внешние, которые покупаются отдельно), дисковод.
Да различную. Текстовую, графическую, видеоинформацию, вроде ещё было два вида, но я их уже не помню.
Звуковой (о, вспомнился четвёртый вид из пяти в предыдущем вопросе), графический, графический.
Предельно кратко: на клавиатуру не смотреть, указательный палец левой руки на кнопке "а", указательный палец правой - на "о". Так и печатаем. Пробел нажимать любым большим пальцем.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота