Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
trybak03
14.11.2020 12:06 •
Информатика
Написать программу, определяющую сумму/количество элементов массива, значение которых больше 1 и меньше 5. на языке с++
Показать ответ
Ответ:
nastushkaplushka
08.10.2020 07:06
#include <iostream>
#include <array>
#include <numeric>
using namespace std;
const size_t N = 10;
int main()
{
size_t sum = 0;
array<int, N> a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 4 };
cout << "Count: ";
cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
if (num > 1 && num < 5) {
++count;
sum += num;
}
return count;
});
cout << " Sum: " << sum << endl;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Xzxzxzxzxzzxzxz
19.02.2023 14:46
Подскажите по информатике s=|x-7|/7+|x-8|/7+|x-9|/9++|x-n|/n вычислить сумму циклом с постусловием...
Вольха97
19.02.2023 14:46
Выбери верное, а) документ является приемником информации да нет б)в документе могут содержатся текстовые данные. а) да, б) нет....
blin42p00v7h
28.08.2022 15:39
по информатике нужно 2 ответа...
0667543784u76ju
01.06.2023 08:47
20 изображений разрешением 1600х1200 пикселей отправили по каналу связи со средней пропускной бит/секунду. Все изображения были приняты приемником не более чем 10 секунд. Известно,...
deniskalubit
23.03.2021 08:45
Файл размером 27 Мбайт передается через некоторое соединение в течение 24 секунд, Сколько секунд будет передаваься файл разме ром 9 Мбайт же соединение? В ответе укажите одно число,...
Danila5555
19.02.2023 07:15
Какие меры безопасности при работе в интернете Ты знаешь...
пппппп41ррр
22.04.2021 03:28
Какой исторический термин означает: А) переход от традиционного общества к индустриальному. Б) группа предприятий, контролирующих производство большей доли товара в какой-либо...
bulyginanastya
07.02.2022 18:23
Что такое работатехника...
ichhund
12.06.2022 14:15
Кристуючисьмасштабом, Визначтемодуль сили F2, що дієна тіло АОЧЕНЬ...
Сашунязайка
22.04.2023 21:56
Можно на английском 40 слов про известного кумира...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <array>
#include <numeric>
using namespace std;
const size_t N = 10;
int main()
{
size_t sum = 0;
array<int, N> a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 4 };
cout << "Count: ";
cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
if (num > 1 && num < 5) {
++count;
sum += num;
}
return count;
});
cout << " Sum: " << sum << endl;
}