В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
1greg
1greg
23.03.2023 14:35 •  Информатика

Написать программу осуществляющую поиск в одномерном массиве a, состоящего из 20 элементов, заданных случайным образом элемента, равного 50. если такого нет, вывести на экран сообщение “такого нет”.

Показать ответ
Ответ:
Ника1511111
Ника1511111
09.10.2020 19:25

var a:array[1..20] of integer;

i,k: integer;

begin

for i:=1 to 20 do

begin

a[i]:=random(51)+25;

write (a[i],' ')

end;

writeln;

for i:=1 to 20 do

if a[i]=50 then

begin

writeln (i,' элемент = ',a[i]);

k:=k+1

end;

if k=0 then writeln ('Такого нет')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота