В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
m18303
m18303
03.03.2020 08:02 •  Информатика

Написать программу Pascal. Найти простые числа х и у, которые в произведении дают число z, типа longint.

Показать ответ
Ответ:
STAS228917654321
STAS228917654321
23.12.2021 06:00

число Z вводится

Pascal

var

 i, z: longint;

begin

 write('Введите Z : ');

 readln(z);

 for i:=1 to trunc(sqrt(z)) do begin

   if z mod i = 0 then

     writeln(i, ' * ', z/i);

 end;  

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота