В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Ира0386
Ира0386
05.07.2021 22:56 •  Информатика

Написать программу pascal с команд if then else. есть прямоугольное отверстие с размерами а и b. пройдет ли в это отверстие восотой m и шириной n

Показать ответ
Ответ:
пожалуйста189
пожалуйста189
08.10.2020 12:41
Чтобы предмет с прямоугольным поперечным сечением в прямоугольное отверстие размером m×n, нужно чтобы минимальный размер стороны отверстия был больше минимального размера в сечении предмета, а максимальный размер стороны отверстия был больше максимального размера в сечении предмета.
Выражение min(a,b) < min(m,n) ∧ max(a,b) < max(m,n) должно принимать значение "истина".

PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadReal2('Введите через пробел размеры балки:');
  var (m,n):=ReadReal2('введите через пробел размеры отверстия:');
  if  (Min(a,b)<Min(m,n)) and (Max(a,b)<Max(m,n)) then
    Writeln('Балка проходит в отверстие')
  else Writeln('Балка не проходит в отверстие')
end.

Пример
Введите через пробел размеры балки: 3.6 4.8
введите через пробел размеры отверстия: 4.2 4
Балка не проходит в отверстие
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота