В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sidorov26812
sidorov26812
11.06.2022 03:15 •  Информатика

Написать программу Паскаль! 1.Вывести на экран и подсчитать количество натуральных чисел типа longint,
которые при делении на заданное простое число х, дают в остатке число у.
2.Найти простые числа х и у, которые в произведении дают число z, типа
longint.

Показать ответ
Ответ:
temaimcheg
temaimcheg
01.02.2022 03:28

Программа:

Pascal:

var

 y: real;

 n, j: longint;

 i, x: integer;

begin

 write('x = ');  readln(x);

 write('y = ');  readln(y);

 j := MAXINT;

 for i := 1 to j do

   if i mod x = y then inc(n);

 writeln(n, ' чисел');

 

end.

Результат:

x =  5

y =  3

429496729 чисел

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота