Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Ожзвэ
07.07.2020 06:25 •
Информатика
Написать программу (паскаль) для нахождения корней квадратного уравнения и ответ
x²-x-6=0
Показать ответ
Ответ:
elizaveta4256
27.03.2023 09:58
#include <iostream>
using namespace std;
int main()
{
double S = 0;
int N = 0, K = 0, A;
cout <<"K = ",cin >> K;
for(int i = 0; i < K; i++)
{
cout <<"Nabor "<<i<<": ";
S = 0;
N = 0;
cin >> A;
while(A != 0)
{
S+=A;
N++;
cin >> A;
}
if (N!=0) cout <<"Sr = "<<S/N<<"\n";
else cout <<"Na noll delit' nel'zja!\n";
}
return 0;
}
0,0
(0 оценок)
Ответ:
Masha00317
18.06.2020 18:52
#include <iostream>
#include <cstring>
int main() {
char* text1 = "Слово";
char* text = "Как то текст с гласными на конце кок";
char* newText = new char[strlen(text)];
int lastStop = 0, lastIter = 0;
for (int i = 0; text[i] != '\0'; i++) {
bool copyIt = false;
if (text[i] == ' ') lastStop = i;
if (text[i + 1] == ' ' || text[i + 1] == '\0') {
for (int j = 0; text1[j] != '\0'; j++) {
if (text[i] == text1[j]) {
copyIt = false; break;
}
copyIt = true;
}
}
if (copyIt == true) {
for (int j = lastStop; j <= i; j++, lastIter++)
newText[lastIter] = text[j];
}
}
for (int i = 0; i < lastIter; i++)
std::cout << newText[i];
std::cout << "\n";
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Катя02122003
14.03.2023 01:38
Необходимо придумать логическое выражение для параметров a b c, которое равно нулю лишь при a=1 b=0 c=1. выражение может содержать лишь операторы конъюнкции, дизъюнкции...
stendec
10.12.2022 00:22
Значения элементов массива m(30) вводятся с клавиатуры. верно ли, что количество положительных элементов в массиве и их сумма четны....
lenayun
29.05.2022 01:18
Запишите на языке Python арифметическое выражение 6,38; ...
annakokesnik
29.05.2022 00:35
Рябят кто может с раскраской фотошопе ...
SonyaNexoda
02.08.2020 13:08
Python информатика 10 класс...
juliati88tan
12.08.2020 17:28
с задачей в Пайтон, фото прикреплено...
79042532294
14.04.2020 18:31
(заранее ! )угол образует биссектриса угла 110 ° с продолжением с одной его сторон?...
атайсуйкнбеков
14.04.2020 18:31
Берилген тиркестерди колданып сойлемдер курандар 7- тапсырма...
Dashe444ki
25.01.2023 12:12
8 класс поэтапный ход революции в франции 48- 49г п 15...
AlexanderVard
04.05.2021 04:14
Выполните действия, используя свойства сложения и вычитания: а) 134+(879+366)= , в) (743+276)-343=, г) 476+843+224+157=...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
int main()
{
double S = 0;
int N = 0, K = 0, A;
cout <<"K = ",cin >> K;
for(int i = 0; i < K; i++)
{
cout <<"Nabor "<<i<<": ";
S = 0;
N = 0;
cin >> A;
while(A != 0)
{
S+=A;
N++;
cin >> A;
}
if (N!=0) cout <<"Sr = "<<S/N<<"\n";
else cout <<"Na noll delit' nel'zja!\n";
}
return 0;
}
#include <cstring>
int main() {
char* text1 = "Слово";
char* text = "Как то текст с гласными на конце кок";
char* newText = new char[strlen(text)];
int lastStop = 0, lastIter = 0;
for (int i = 0; text[i] != '\0'; i++) {
bool copyIt = false;
if (text[i] == ' ') lastStop = i;
if (text[i + 1] == ' ' || text[i + 1] == '\0') {
for (int j = 0; text1[j] != '\0'; j++) {
if (text[i] == text1[j]) {
copyIt = false; break;
}
copyIt = true;
}
}
if (copyIt == true) {
for (int j = lastStop; j <= i; j++, lastIter++)
newText[lastIter] = text[j];
}
}
for (int i = 0; i < lastIter; i++)
std::cout << newText[i];
std::cout << "\n";
return 0;
}