В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Matveu331
Matveu331
27.10.2020 16:43 •  Информатика

Написать программу паскаль. каждый трехмерной целочисленной матрицы домножить на сумму его индексов.​

Показать ответ
Ответ:
jumalieva03
jumalieva03
30.09.2020 15:17

Я не уверен, но наверно как то так

Var i, j, l:Integer ;

A:array[1..100,1..100,1..100]of Integer ;

Begin

For i:=1 to 10 do

For j:=1 to 10 do

For l:=1 to 10 do begin

A[i,j, l]:=random(10);

Write ('A[', i, ', ', j, ', ', l, ']= ', A[i, j, l]) ;

End ;writeln;

For i:=1 to 10 do

For j:=1 to 10 do

For l:=1 to 10 do begin

A[i, j, l] :=A[i, j, l] *(i+j+l) ;

Write ('A[', i, ', ', j, ', ', l, ']= ', A[i, j, l]) ;

End;

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота