Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Homchik111
18.02.2023 20:57 •
Информатика
Написать программу паскаль, которая формирует массив, элементами которого являются цифры заданного натурального числа.
Показать ответ
Ответ:
Angelina5353
07.07.2020 21:49
var
a: array of byte; //char?
b, d: integer;
begin
readln(b);
SetLength(a, length(IntToStr(b)));
for d := 0 to length(a) - 1 do
begin
a[d] := b mod 10;
b := b div 10;
end;
for d := 0 to (length(a) - 1) do
write(a[d], ' ');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Djjdcnudghu
06.05.2020 19:43
надежность паролей урок второй Определи причину по которой необходимо указывать имя инициалы при создании текстового документа Microsoft Word для предотвращения удаление файлов...
Вова3371346
02.09.2022 00:53
Сравни компьютерные и биологические вирусы с диаграммы Венна какой из них опаснец...
LumpySpacePrincess01
04.10.2021 20:33
Определи вид скобок, который Используется для создания гиперссылки на автора или источник, из которого заимствован фрагмент текста. УМОЛЯЮЮЮМНЕ НУЖНО ...
Математикаалгебра
07.12.2021 00:54
Решить, ! паскаль в 2-хфайлах хранятся натуральные числа подсчитать количество повторяющихся чисел...
kanony
10.06.2022 22:15
Определите количество информации для двоичного кодирования 8 цветов?...
cerrys12
16.10.2022 01:18
Уберите лишнее. базовое по включает в себя: a) сетевые операционные системы в) программы архивирования с) оболочки d) операционные системы...
Gerri11
30.08.2022 00:05
Нужно как из четырёхзначного числа сравнить первую и последнюю цифру и две средних вопрос в том что как их вытащить из этого числа? первую и последнюю я понял как console.writeline(...
ksenia20012002
17.01.2022 19:32
2. На дисплее планшетного компьютера в режиме чтения помещается 16 строк, каждая из которых содержит 32 символа. Сколько страниц займёт книга в кодировке ASCII, если её информационный...
lanv
06.08.2022 13:43
оклад працівника дорівнює s грн якщо він якісно виконує завдання йому нараховується премія в розмірі 50% окладу розробіть програму визначення реальної заробітної платні працівника...
annagrits66
21.04.2021 01:29
10. Складіть проект, у якому виконавець зменшить свій образ на 10, якщо до виконавця доторкається вказівник миші, переміститьсявправо на 100, якщо натиснуто клавішу стрілка...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a: array of byte; //char?
b, d: integer;
begin
readln(b);
SetLength(a, length(IntToStr(b)));
for d := 0 to length(a) - 1 do
begin
a[d] := b mod 10;
b := b div 10;
end;
for d := 0 to (length(a) - 1) do
write(a[d], ' ');
end.