В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
13573967
13573967
06.07.2020 08:08 •  Информатика

написать программу Паскаль которая находит корни квадратного уравнения. D>0, D=0 С Else, if, then

Как на картинке , только без ошибок


написать программу Паскаль которая находит корни квадратного уравнения. D>0, D=0 С Else, if, then

Показать ответ
Ответ:
QwErtY314455667
QwErtY314455667
03.04.2021 22:43
1.
var
  k, sum, n, i: integer;
  A: array of integer;
begin
  writeln('Введите размерность массива: ');
  readln(n);
  SetLength(A, n);
  writeln('Введите K: ');
  readln(k);
  writeln('Введите ', n, ' элементов массива :');
  for i := 0 to n - 1 do
  begin
    readln(A[i]);
    if A[i] mod k = 0 then sum := sum + A[i];
  end;
  writeln('Результат: ', sum);
end.

2.
var
  c, k, n, i: integer;
  B, A: array of integer;
begin
  k := 1;
  writeln('Введите размерность массива: ');
  readln(n);
  SetLength(A, n + 1);
  writeln('Введите ', n, ' элементов массива :');
  for i := 1 to n do
  begin
    readln(A[i]);
    if A[i] = 0 then 
    begin
      inc(c);
      SetLength(B, c + 1);
      B[k] := i;
      inc(k)
    end;
  end;
  writeln('Позиции нулевых элементов: ');
  for i := 1 to c do write(B[i]:3);
end.
0,0(0 оценок)
Ответ:
boha3
boha3
13.02.2023 07:38
NortonCommander - Файловый менеджер
WinRar - Программа архивирования
keyboard.drv, sound.drv, mouse.drv - Драйвера устройств клавиатуры, аудио и мышки
«1С Предприятие» - программные продукты для автоматизации бухгалтерского и управленческого учёта

MSWord, Блокнот - текстовые редакторы
MSExcel - табличный редактор
MSAccess - реляционная СУБД
3DStudio - редактор трёхмерной графики
Си, Basic, Pascal, C+, Фортран, FoxPro - Языки программирования
Linux, Windows7 - Операционные системы
AdobePhotoshop, Paint - графический редактор
MacromediaFlash - медиа-плеер
Компас 3D - САПР(Система автоматизированного проектирования)
QIP - интернет-пейджер
AVP Касперского, DrWeb - антивирусная программа
OutlookExpress - почтовый клиент и органайзер
HTML - язык гипертекстовой разметки
NeroPremium - программа записи дисков
«Консультант Плюс» - Справочная система

P.S. Вроде всё описал, если нужны объяснения пишите
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота