В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
bigman4
bigman4
24.02.2020 09:29 •  Информатика

Написать программу(паскаль). с пояснениями, желательно. нужно с for. найти сумму всех n-значных чисел, кратных k.(1 < (или равно) n< (или равно)4).

Показать ответ
Ответ:
katmar
katmar
30.09.2020 21:15

program sada;

var k,n,res,i:integer;

     temp:string;

begin

res:=0;

readln(k);

temp:='';

for i:=1 to n do

temp:=temp+'9';

n:=strtoint(temp);

for i:=1 to n do begin

if (i mod k = 0) then res:=res+i;

end;

writeln(res);

end.

 

 

p.s. Программа написана на pascalABC

0,0(0 оценок)
Ответ:
ЭмилиСтоун11
ЭмилиСтоун11
30.09.2020 21:15

var

  k, n, Summ, i, max, min:integer;

begin

  write('n = '); readln(n);

  write('k = '); readln(k);

  max := 9;

  min := 1;

  for i := 2 to n do

  begin

    max := max * 10 + 9;

    min := min * 10;

  end;

  for i := min to max do

    if i mod k = 0 then

      Summ := Summ + i;

  writeln('Сумма = ', Summ);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота