В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
rudaniladanilov
rudaniladanilov
29.04.2023 06:44 •  Информатика

Написать программу паскаля, которая определяет делится ли число на 3 ,но не делятся на две.

Написать программу Паскаля ,которая определяет делится ли число на 5 ​​

Показать ответ
Ответ:
Sherstev
Sherstev
02.02.2021 23:40

В строке №8 записываем операцию умножения.

В строке №10 записываем операцию деления. Ее отличие от операции «Div» в том, делить можно дробные числа и результате операции могут получаться дробные числа. Запомните, что операция деления «/» не производится над переменными целого типа integer, т.к. в результате такой операции могут получиться дробные числа, и программа выдаст ошибку.


Написать программу паскаля, которая определяет делится ли число на 3 ,но не делятся на две.Написать
0,0(0 оценок)
Ответ:
Irinad27
Irinad27
02.02.2021 23:40

3.

program 1;

a:integer;

Begin

write ('a= ');

readln (a);

if (a mod 3=0) then

writeln ('да делится) ;

else

writeln('не делится');

readln;

end.

5.

var n:integer;

begin

write('n=');

readln(n);

if n mod 5=0 then write('Число кратно 5')

else write('Число нужно увеличить на ',5-n mod 5)

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота