В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
мurr
мurr
19.10.2020 12:51 •  Информатика

Написать программу перевода числа из двоичной системы в десятичную с использованием функции возведения в степень. я написала, но у меня где-то ошибка. b: =0; m: =length(max)-1; j: =m; for i: =1 to m do begin val(max[i],p,code); while j> =0 do p: =p*step(2,j); b: =b+p; j: =j-1; writeln(b); end; поясняю, что тут и как. эта мини-, входящая в решение одной масштабной . дана строка max, в которой записано двоичное число. функция step(x,y: integer): integer возводит число x в степень y. найти и исправить ошибку, только, , не надо писать совершенно другой решения. заранее ))

Показать ответ
Ответ:
Рюзаки1
Рюзаки1
01.10.2020 23:04
Begin
 
  max := '1010';
  b := 0;
  m := length(max);
  j := m - 1;
 
  for i := 1 to m do
 
  begin
   
    val(max[i], p, code);
   
    {while j >= 0 do}
   
    p := p * step(2, j);
   
    b := b + p;
    j := j - 1;
   
    writeln(b);
   
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота