В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ixnivoodoo
ixnivoodoo
30.12.2022 18:14 •  Информатика

Написать программу перевода из десятичной системы счисления в двоичную при функций пользователя. паскаль(функции пользователя).

Показать ответ
Ответ:
regenko1
regenko1
05.10.2020 09:12
Program n1;
var n: integer;
function per(n: integer ): integer;
var
a: array[1..500] of integer;
i,c:integer;
begin
c:= 0;
repeat
c:= c + 1;
a[c]:= n mod 2;
n:= n div 2;
until n = 0;
for i:= c downto 1 do
write(a[i]);
end;
begin
write('введите число: ');
readln(n);
per(n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота