написать программу. Плата за пользование электроэнергией исчисляется по следующему правилу: за первые 90 квт/ч взыскивается по 7.6 коп за каждый израсходованный киловатт-час, а за каждый последующий — в два раза больше. Составить программу, которая по запросу вводит количество израсходованной в месяц энергии, вычисляет и выводит на экран начисленную к оплате сумму.
(Обозначим: n - вводимое число; m - дубликат числа n; а - перевертыш числа n; i - переменная цикла для создания перевертыша.)
program prim3;
uses crt;
var n, m, a, i: integer;
begin
clrscr;
(Введем четырехзначное целое число.)
writeln('N<=9999'); readln(n)
(Запоминаем введенное целое число и задаем начальное значение перевертыша.)
m:=n;а:=0;
(Организуем цикл с параметром от 1 до 4.)
for i:=l to 4 do
(Находим перевертыш числа N)
begin
а:=а*10+ m mod 10; m:= m div 10;
end;
(Если A=N, то данное число является перевертышем.)
if a=n then writeln('DA!')
else writeln('NO');
readln;
end.
Слово «алгоритм» происходит от имени великого Персидского учёного Мухаммеда аль-Хорезми́, жившего в первой половине IX ве́ка (точные годы его жизни неизвестны, но считается, что он родился около 780 года, а умер около 850). «Аль-Хорезми» означает «из Хорезма» (исторической области в нынешнем Узбекистане, центром которой был город Хива).
Около 825 года аль-Хорезми написал сочинение, в котором впервые дал описание придуманной в Индии позиционной десятичной системы счисления. К сожалению, арабский оригинал его книги не сохранился, так что её оригинальное название нам неизвестно. Аль-Хорезми сформулировал правила вычислений в новой системе и, вероятно, впервые использовал цифру 0 для обозначения пропущенной позиции в записи числа (её индийское название арабы перевели как as-sifr или просто sifr, отсюда такие слова, как цифра и шифр). Приблизительно в это же время индийские цифры начали применять и другие арабские учёные. В первой половине XII века книга аль-Хорезми в латинском переводе проникла в Европу. Переводчик, имя которого до нас не дошло, дал ей название «Algoritmi de numero Indorum» («Индийское искусство счёта, сочинение Аль-Хорезми»).
Таким образом, мы видим, что латинизированное имя аль-Хорезми было вынесено в заглавие книги, и сегодня ни у кого нет сомнений, что слово «алгоритм» попало в европейские языки именно благодаря этому сочинению. Однако вопрос о его смысле длительное время вызывал ожесточённые споры. На протяжении многих веков происхождению слова давались самые разные объяснения.
Одни выводили algorism из греческих algiros (больной) и arithmos (число). Из такого объяснения не очень ясно, почему числа именно «больные». Или же лингвистам больными казались люди, имеющие несчастье заниматься вычислениями? Своё объяснение предлагала и знаменитая энциклопедия Брокгауза и Ефрона (1890 год). В ней алгорифм (кстати, до революции использовалось написание алгориѳм, через «фиту») производится «от арабского слова Аль-Горетм, т. е. корень». Разумеется, эти объяснения вряд ли можно счесть убедительными.