В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу по информатике на паскале. создать с клавиатуры массив из трех чисел-первое число от 1 до 25, второе от 26 до 50, третье от 51 до 100. создать второй массив случайным образом по таким же правилам. сравнить эти числа и написать сколько совпало

Показать ответ
Ответ:
mikrob22
mikrob22
07.10.2020 12:13
Type mas=array[1..3] of integer;
var a,b:mas;
i,k:integer;
procedure proc(var x:mas);
var i:integer;
begin
x[1]:=random(25)+1;
x[2]:=random(25)+26;
x[3]:=random(50)+51;
for i:=1 to 3 do write(x[i],' ');
writeln;
end;
begin
randomize;
writeln('1-й массив:');
proc(a);
writeln('2-й массив:');
proc(b);
k:=0;
for i:=1 to 3 do
 if a[i]=b[i] then k:=k+1;
writeln('Число совпавших элементов = ',k);
end.

Пример:
1-й массив:
6 29 58
2-й массив:
21 29 63
Число совпавших элементов = 1
0,0(0 оценок)
Ответ:
птимзшктвіал
птимзшктвіал
07.10.2020 12:13
Var a,b:array[1..3] of integer;
begin
a[1]:=Random(26); b[1]:=Random(26);
a[2]:=Random(26)+25; b[2]:=Random(26)+25;
a[3]:=Random(51)+50; b[3]:=Random(51)+50;
writeln(a[1],' ',a[2],' ',a[3]);
writeln(b[1],' ',b[2],' ',b[3]);
if (a[1]=b[1]) and (a[2]=b[2]) and (a[3]=b[3])
then writeln('Совпало 3')
else
if ((a[1]=b[1]) and (a[2]=b[2])) or ((a[2]=b[2]) and (a[3]=b[3])) or ((a[1]=b[1]) and (a[3]=b[3]))
then writeln('Совпало 2')
else
if (a[1]=b[1]) or (a[2]=b[2]) or (a[3]=b[3])
then writeln('Совпало 1')
else writeln('Совпадений нет');
end.

P.S Писал не на компьютере, возможны ошибки, проверьте и в случае если обнаружатся ошибки, напишите мне
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота