В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
gasha1234567890
gasha1234567890
21.05.2022 23:30 •  Информатика

написать программу по информатике. Нужно записать программу на языке Паскаль. Баскетбольный мячик должен лететь в кольцо и попасть в него

Показать ответ
Ответ:
denissss2222
denissss2222
06.04.2023 20:10
Не уверен, что в 9 классе проходят массивы, уточни потом, переделаю, если что.

Program G;
Uses Crt;
Var NumS: Array [1..10] of byte;
    n: integer; count, i, k, equal, truth: byte;
Begin
 ClrScr;
 Truth:=0;
 Writeln('Введите число N (меньше или равное 9999).');
 Repeat
  Readln(N);
  If N>9999 then Writeln('Введено неверное число. Повторите ввод.');
 Until N<=9999; Count:=0;
 While N>0 do
  Begin
   Inc(Count);
   NumS[Count]:=N mod 10;
   N:=N div 10;
  End;
 For i:=1 to Count do
  Begin
   Equal:=0;
    For k:=i+1 to Count do
    If NumS[i]=NumS[k] then
     Inc(Equal);
   If Equal=2 then Truth:=1;
  End;
 If Truth=1 then Writeln('В числе совпадает три разряда.')
   Else Writeln('В числе совпадает менее/более трёх разрядов.');
 Readln;
End.
0,0(0 оценок)
Ответ:
bobbobbobgy1
bobbobbobgy1
13.03.2022 09:28
1.
Program Yolo;
Uses Crt;
Var x, count, amount, n: integer;
Begin 
ClrScr; 
Amount:=0; Count:=0; 
Writeln('Введите кол-во чисел необходимых ввести.'); 
Readln(n); 
While Amount<n do 
 Begin   
  Inc(Amount);   
  Writeln('Введите число.');   
  Readln(x);   
  If (x<=100) and (x mod 5=0) then
    Inc(Count);
 End;
ClrScr;
If Count>0 then Writeln('Количество чисел, кратных 5 и не больших 100: ', Count)
  Else Writeln('Среди введёных чисел не было кратных 5 и не больших 100.');
 Readln;
End.

2.
Program Yolo;
Uses Crt;
Const N=10;
Var Mass: Array [1..N] of integer;
      i, SummPosit, AmountNegat: byte;
 Begin
 ClrScr;
 SummPosit:=0;
 AmountNegat:=0;
 Writeln('Массив чисел из диапозона [-50; 50]: ');
 For i:=1 to N do
  Begin
   Mass[i]:=Random(101)-50;
   Write(Mass[i], ' ');
   If Mass[i]>0 then Inc(SummPosit, Mass[i])
    Else If Mass[i]<0 then Inc(AmountNegat);
  End; Writeln; If SummPosit>0 then
 Writeln('Сумма положительных элементов массива: ', SummPosit)
  Else Writeln('В массиве нету положительных элементов.');
 If AmountNegat>0 then
 Writeln('Количество отрицательных элементов массива: ', AmountNegat)   Else Writeln('В массиве нету отрицательных элементов.');
 Readln;End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота