В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
79521312181
79521312181
06.08.2020 09:37 •  Информатика

Написать программу подсчета цифр заданного n-значного числа. указать, какие из этих цифр являются простыми. в паскале

Показать ответ
Ответ:
annbobrovska
annbobrovska
16.04.2023 10:03

#include <iostream>

using namespace std;

int main()

{

int arr[]{10,8,3,9,15,25,38};

int buff; // временная переменная для обмена элементов местами

   // Сортировка массива пузырьком

   for (int i = 0; i < size - 1; i++) {

       for (int j = 0; j < size - i - 1; j++) {

           if (arr[j] > arr[j + 1]) {

               // меняем элементы местами

               buff = arr[j];

               arr[j] = arr[j + 1];

               arr[j + 1] = buff;

           }

       }

   }

   // Вывод отсортированного массива на экран

for (int i = 0; i < size; i++)

{

   cout << arr[i] << " ";

}

   cout << endl;    

   return 0;

}

0,0(0 оценок)
Ответ:
drart77
drart77
16.04.2023 10:03

#include <iostream>

using namespace std;

int main()

{

int arr[]{10,8,3,9,15,25,38};

int buff; // временная переменная для обмена элементов местами

  // Сортировка массива пузырьком

  for (int i = 0; i < size - 1; i++) {

      for (int j = 0; j < size - i - 1; j++) {

          if (arr[j] > arr[j + 1]) {

              // меняем элементы местами

              buff = arr[j];

              arr[j] = arr[j + 1];

              arr[j + 1] = buff;

          }

      }

  }

  // Вывод отсортированного массива на экран

for (int i = 0; i < size; i++)

{

  cout << arr[i] << " ";

}

  cout << endl;    

  return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота