В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу: подсчитать сумму двузначных четных чисел в диапазоне заданном пользователем. используя оператор !

Показать ответ
Ответ:
maratabdullin1p0dtuc
maratabdullin1p0dtuc
06.10.2020 06:15
Для наглядности и простоты проверки оставил вывод слагаемых:

Var S,a,b:integer;
Begin
WriteLn('Сумма нечётных двузначных чисел в [a,b]');
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
S:=0;
if a mod 2 = 0 then a:=a+1;
if a < -10 then
   Begin
   if a < -99 then a:=-99;
   Repeat
   S:=S+a;
   WriteLn(a);
   a:=a+2;
   Until (a>-11)or(a>b);
   a:=11;
   End;
if (b>10)and(a<100) then
   Repeat
   S:=S+a;
   WriteLn(a);
   a:=a+2;
   Until (a>99)or(a>b);
WriteLn('S = ',S)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота