В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Syrtou
Syrtou
01.06.2021 11:00 •  Информатика

Написать программу подсчитывающая количество четных и несчетных цифр в числе. Алгоритм
1.Ввести число n
2.Присвоить переменной even=0(четных),переменной odd=0(несчетных)
3.Условия n>0,если число без остатка на 2,то even:=even+1,не делиться на 2,значит odd:=odd+1
4.Избавляемся от младшего разряда делением на 10(div10)

Показать ответ
Ответ:
5352352356
5352352356
12.04.2022 15:12
#include "stdio.h"

main()
  int N = 10, count = 0, z = 5, i;
  int m[N];
  double res = 0

  for(i = 0, i < N, i++)
    if ((m[i] >= -3) && (m[i] <= 3))
    {
      count++;
      res = res + m[i];
    }

  if (count == 0)
    res = 0;
  else
     res = res / count;

  if (res > z)
  {
    res = 0;
    for(i = 0; i < N; i++)
      if (m[i] % 2 == 0)
        res = res + m[i];
  }
  else
  {
    res = 1;
    for(i = 0; i < N; i++)
      if (m[i] % 2 != 0)
        res = res * m[i];
  }

  printf("Z = %f", res);
}
0,0(0 оценок)
Ответ:
HeZnAiKaxXx
HeZnAiKaxXx
19.02.2022 13:13
                                        ДВОРНЯГА
                                       ШАРИК ТУЗИК БАРБОС
                                            БУЛЬДОГ
                                              цезарь 
                                               граф
                                                васнсар
                                                   гари   
                                                   пудель
                                                    эмма белла джозефина стелла

                                                     
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота