В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Kseniakool
Kseniakool
07.11.2020 13:41 •  Информатика

Написать программу поиска 3 элементов из 50 элементов массива (в паскале) 9 класс

Показать ответ
Ответ:
Lololiplolpjvfhsbf
Lololiplolpjvfhsbf
18.05.2020 09:17

1)

var

i, n, a: integer;

begin

readln(n);

for i:= 1 to n do

begin

 writeln('Введите число a: ');

 readln(a);

 if a mod 10 = 4) and (a > 10) and (a < 100) then

   writeln(a);

 writeln('Введите кол-во чисел n: ');

 writeln('В данный момент n = ', n);

 readln(n);

 if n = 0 then break;

 end;

end.

2)

var

i, n, a, z, min: integer;

begin

readln(n);

z:= 0;

for i:= 1 to n do

begin

 writeln('Введите число a: ');

 readln(a);

 z:= z + 1;

 if (i <> 0) and (z = 1) then

   min:= a;

 if (a < min) then min:= a;

 writeln('Введите кол-во чисел n: ');

 writeln('В данный момент n = ', n);

 readln(n);

 if n = 0 then break;

 end;

writeln(min)

end.

0,0(0 оценок)
Ответ:
bobrovpasha
bobrovpasha
18.05.2020 09:17

1)

var

i, n, a: integer;

begin

readln(n);

for i:= 1 to n do

begin

 writeln('Введите число a: ');

 readln(a);

 if a mod 10 = 4) and (a > 10) and (a < 100) then

   writeln(a);

 writeln('Введите кол-во чисел n: ');

 writeln('В данный момент n = ', n);

 readln(n);

 if n = 0 then break;

 end;

end.

2)

var

i, n, a, z, min: integer;

begin

readln(n);

z:= 0;

for i:= 1 to n do

begin

 writeln('Введите число a: ');

 readln(a);

 z:= z + 1;

 if (i <> 0) and (z = 1) then

   min:= a;

 if (a < min) then min:= a;

 writeln('Введите кол-во чисел n: ');

 writeln('В данный момент n = ', n);

 readln(n);

 if n = 0 then break;

 end;

writeln(min)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота