Написать программу поиска чисел , лежащих в интервале от -5 до 5, в последовательности чисел, вводимых с клавиатуры, предшествующих первому ведённому нулю. контрольный пример 1, 10, -4 , 5, -16, 5, использовать именно c++ , цикл for
Язык программирования не указан, потому - самый простой вариант - программа на паскале. Даже на паскале задачу можно решать различными с массивом, без массива, со строками, без строк. Опять-таки, самый простой вариант - со строками. var s,p:string; n,i:integer; begin writeln('Введите символы:'); readln(s); n:=pos('.',s)-1; writeln('n = ',n); p:=''; for i:=1 to n do p:=s[i]+p; writeln('а)'); writeln(p); p:=''; if n mod 2 = 0 then i:=2 else i:=1; while i<=n do begin p:=p+s[i]; i:=i+2; end; writeln('б)'); writeln(p); end.
Пример: Введите символы:Даны символы s1, s2, ... Известно, что символ s1 отличен от точки n = 21 а) ,2s ,1s ыловмис ынаД б) Дн ивл 1 2
Inkscape (Инкскейп) — свободно распространяемый векторный графический редактор, удобен для создания как художественных, так и технических иллюстраций (вплоть до использования в качестве САПР общего назначения, чему также лёгкость обмена чертежами). Это стало возможным во многом благодаря открытому формату SVG, развиваемому консорциумом W3C. Формат SVG позволяет создавать иллюстрации различного типа, в том числе анимированные. Поскольку SVG основан на расширяемом языке разметки (XML), к нему можно писать расширения, чем авторы Inkscape и пользуются[8]. Программа распространяется на условиях GNU General Public License.
var s,p:string; n,i:integer;
begin
writeln('Введите символы:');
readln(s);
n:=pos('.',s)-1;
writeln('n = ',n);
p:='';
for i:=1 to n do p:=s[i]+p;
writeln('а)');
writeln(p);
p:='';
if n mod 2 = 0 then i:=2 else i:=1;
while i<=n do
begin
p:=p+s[i];
i:=i+2;
end;
writeln('б)');
writeln(p);
end.
Пример:
Введите символы:Даны символы s1, s2, ... Известно, что символ s1 отличен от точки
n = 21
а)
,2s ,1s ыловмис ынаД
б)
Дн ивл 1 2
Inkscape (Инкскейп) — свободно распространяемый векторный графический редактор, удобен для создания как художественных, так и технических иллюстраций (вплоть до использования в качестве САПР общего назначения, чему также лёгкость обмена чертежами). Это стало возможным во многом благодаря открытому формату SVG, развиваемому консорциумом W3C. Формат SVG позволяет создавать иллюстрации различного типа, в том числе анимированные. Поскольку SVG основан на расширяемом языке разметки (XML), к нему можно писать расширения, чем авторы Inkscape и пользуются[8]. Программа распространяется на условиях GNU General Public License.