В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
gamegame2006
gamegame2006
11.08.2022 19:45 •  Информатика

Написать программу поиска любого элемента в массиве. для уточнения - на языке программирования, для программы паскаль.

Показать ответ
Ответ:
Program pm;
uses crt;
var X:array[1..1000] of integer; k,a,b,i:integer;
begin
clrscr;
write('Введите кол-во элементов массива: ');
read(k);
writeln;
write('Введите диапазон значений заполнения(A-начальное значение, B-конечное): ');
repeat
read(a,b);
until a<=b;
writeln;
randomize;
for i:=1 to k do X[i]:=random(b-a+1)+a;
writeln('Ваш массив:');
for i:=1 to k do write(X[i]:5);
writeln;
write('Введите элемент поиска: ');
read(b);
a:=0;
for i:=1 to k do if X[i]=b then a:=i;
if a>0 then writeln('Элемент со значением ',b,' имеет индекс ',a)
else writeln('Элемента не существует!');
readkey;
end.
0,0(0 оценок)
Ответ:
yuliyanaumenko2
yuliyanaumenko2
02.10.2020 11:38
Поиска индекса элемента по заданному значению или поиска значения по заданному индексу? Напишу решение для обоих случаев.
1.
Поиск элемента по заданному индексу
var
n:longint;
m:array[1..1000] of longint;
begin
writeln('Введите индекс элемента массива');
read(n);
writeln('Элемент под номером ',n,' равен ',m[n]);
end.

2. Поиск индекса по заданному значению в неупорядоченном массиве:
var
n,i:longint;
m:array[1..1000] of longint;
begin
read(n);
i:=1;
while m[i]<>n do
i:=i+1;
writeln(m[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота