В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу поиска любого элемента в массиве с рекурсии на с++

Показать ответ
Ответ:
KatyaKerina
KatyaKerina
08.06.2022 14:48
1. Шестнадцатиричное представление переводим в десятичное.
Записываем 4A98 в расширенной форме по степеням основания (т.е. 16 в нашем случае):
4A98.BC2_{16}=4\times 16^3+10\times 16^2+9\times 16^1+8\times 16^0+ \\ 11\times 16^{-1}+12\times 16^{-2}+2\times 16^{-3}= \\ 16384+2560+144+8+ \frac{11}{16}+ \frac{12}{256}+ \frac{2}{4096} =19096\frac{1505}{2048}}= \\ 19096.73486328125_{10}
2. Шестнадцатиричное представление переводим в восьмеричное.
Поскольку 16=2^4; \ 8=2^3, перевод удобно сделать через промежуточную двоичную систему.
Каждую шестнадцатиричную цифру заменяем четырьмя двоичными цифрами (так называемой тетрАдой).
0100 1010 1001 1000 . 1011 1100 0010 (2)
Разбиваем двоичное число на триАды (по три разряда) влево и вправо от десятичной точки и каждую триаду заменяем восьмеричной цифрой (они по написанию совпадают с десятичными). Если разрядов для триады не хватает, дополняем их нулями слева для целой части и справа для дробной.
100101010011000.10111100001 (2)= 100 101 010 011 000.101 111 000 010=
45230.5702(8)

ответ: 4A98.BC2(16)=19096.73486328125(10)=45230.5702(8)
0,0(0 оценок)
Ответ:
BrainDay12
BrainDay12
20.08.2022 11:14
 var
b:array [1..100] of integer;
   a:array [1..100,1..100] of integer;
   i, j,n,m,k1,k2: integer;
begin
writeln ('Введите Кол-во строк');
readln (n);
writeln ('Введите Кол-во столбцов');
readln (m);
writeln ('Введите к1');
readln (k1);
writeln ('Введите к2');
readln (k2);
for i :=1 to n do
      for j :=1 to m do
         readln ( a [ i , j ]);
         writeln ('Исходный массив');
         for i:=1 to n do
begin
  for j:=1 to m do
  write(a[i,j]:4);
  writeln;
end;
writeln;
     for j :=1 to m do
       b[j]:=a[k1][j];
         for j :=1 to m do begin
        a[k1][j]:=a[k2][j];
        a[k2][j]:=b[j];
      end;
      writeln ('Массив после операций');
      for i:=1 to n do
begin
  for j:=1 to m do
  write(a[i,j]:4);
  writeln;
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота