В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sw321
sw321
20.02.2021 20:35 •  Информатика

Написать программу (полностью) для нахождения произведение суммы нечетных цифр и их минимума в четырехзначном числе. программа должна начинаться следующим образом и не содержать иных переменных кроме данных. var min, digit, s, n, res : integer; begin readln(n); входные данные: четырехзначное число. выходные данные: результат

Показать ответ
Ответ:
птмпль
птмпль
17.08.2020 08:28

... - уже данный код в условии

s := 0;

min := 10;

for res := 1 to 4 do

begin

digit := n mod 10;

if (digit mod 2 = 1) then

begin

s += digit;

if (digit < min) then

min := digit;

end;

n := n div 10;

end;

writeln(s * min);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота