В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Nezox1123
Nezox1123
17.01.2020 05:34 •  Информатика

Написать программу: при вводе числа в двоичной системе нужно посчитать количество нолей и единиц а при вводе числа больше 1 будет выдавать error​

Показать ответ
Ответ:
Kkttkk
Kkttkk
13.06.2020 15:40

На Python:

number = input('Введите число в двоичной системе счисления: ')

number_of_zeros = 0

number_of_units = 0

for i in number:

   if i == '0':

       number_of_zeros += 1

   elif i == '1':

       number_of_units += 1

try:

#    print('Введеное число: ' + str(int(number, 2)))

   print('Нулей: ' + str(number_of_zeros))

   print('Единиц: ' + str(number_of_units))

except ValueError:

   print('Error')

Объяснение:

закомментировал строку вывода числа в десятичной системе, если понадобится, можно раскомментировать (убрать #), если совсем не надо, можно удалить.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота