В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
emilyblack80
emilyblack80
03.05.2020 13:38 •  Информатика

Написать программу, принимающую арифметическое выражение в виде строки, и определяющую корректность расстановки скобок в этом выражении. Учесть круглые «()»,
квадратные«[]», фигурные «{}» и угловые «<>» скобки.
Скобки считаются сбалансированными, если:
a) количество открывающихся скобок совпадает с количеством закрывающихся;
b) закрывающаяся скобка не идет раньше соответствующей ей открывающейся;
c) соблюдается принцип вложенности скобок

Показать ответ
Ответ:
ЮляЯяя1111
ЮляЯяя1111
30.04.2020 20:00

program weight_class;

var x, y:integer;

label 10,20;

 begin

   10:Writeln ('введите вес спорсмена в кг');

   Readln(x);

   if x<69 then

     Writeln('Спортсмен весом ', x, 'кг, относится к легкой категории');

   if (x>=69) and (x<85) then

   Writeln('Спортсмен весом ', x, 'кг, относится к средней категории');

   if (x>=85) and (x<105) then

   Writeln('Спортсмен весом ', x, 'кг, относится к тяжелой категории');

    if x>=105 then

   Writeln('Спортсмен весом ', x, 'кг, относится к супертяжелой категории');

   Writeln(' Будете еще вводить вес спортсмена: 1-Да, другая любая цифра-Нет');

   Readln (y);

   if y=1then

     goto 10;

  end.

Объяснение:

0,0(0 оценок)
Ответ:
Dffgvfh
Dffgvfh
22.02.2022 20:09

Электронная почта - это основное средство коммуникаций Internet. Она во многом похожа на обычную почту. С ее письмо - текст, снабженный стандартным заголовком (конвертом) - доставляется по указанному адресу, который определяет местонахождение сервера и имя адресата, который имеет почтовый ящик на этом сервере, с тем, чтобы адресат мог его достать и прочесть в удобное время.

Электронная почта оказалась во многом удобнее обычной, "бумажной". Не говоря уже о том, что не приходится вставать из-за компьютера и идти до почтового ящика, чтобы получить или отправить письмо.

Электронная почта является наиболее популярным дополнением к вычислительным сетям. Это но весьма полезное средство. При использовании для связи между сотрудниками всего офиса она оказывается удобнее телефона, так как позволяет передавать отчеты, таблицы, диаграммы и рисунки, которые по телефону передать трудно.

Для электронной почты выпускается довольно много программных продуктов, поэтому с выбором нет проблем. Так, в некоторых случаях даже поставщики операционных систем уже комплектуют свои продукты средствами поддержки электронной почты. Обычно электронная почта работает в пределах локальной сети, но такие системы глобальных вычислительных сетей, как MCI Mail, INTERNET, RELCOM, CompuServe и др., предлагаю‏т электронно-почтовые услуги в национальном и даже в мировом масштабе. Работа электронной почты, не зависит от разницы в часовых поясах, и можно вести переписку с электронной почты с адресатом, который находится на другом конце света.

Обычно для создания и получения сообщений электронной почты применяются специальные почтовые программы, такие как Microsoft Outlook Express, Netscape Composer, The Bat, Eudora Pegasus, Microsoft Outlook и т.д..

Хотя электронная почта может рассматриваться как частный случай передачи файлов, она имеет ряд особенностей, не привычных для стандартных процедур пересылки файлов. Во-первых, отправитель и получатель почти всегда люди, а не машины. Это означает, что служба электронной почты состоит из двух различных, но тесно взаимосвязанных частей: одна обеспечивает взаимодействие с человеком (например, составление, редактирование, прочтение сообщений), другая - передачу сообщений (например, рассылка по спискам, обеспечение передачи).

Другое различие между электронной почтой и средствами передачи файлов общего назначения состоит в том, что почтовые послания представляют собой четко структурированный документ. Во многих системах каждое послание сопровождается большим количеством дополнительных полей. Они включают в себя имя и адрес отправителя, имя и адрес получателя, дату и время отправки письма, перечень людей, которым направлена копия письма, уровень значимости, степень секретности и многое другое.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота