В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Ivanvipmarhade
Ivanvipmarhade
17.08.2021 19:30 •  Информатика

Написать программу, принимающую на вход три целых числа, а затем выводящую на экран по одному случайному целому числу из диапазона от 1 до 2A (A - порядковый номер первой буквы Вашего имени в русском алфавите), ожидая между выводами нажатия любой клавиши. Как только полученное случайное число совпадёт с одним из чисел, полученных на вход, программа должна подождать нажатия любой клавиши, а затем завершить работу В Фотографии пример

Показать ответ
Ответ:
vikfffff
vikfffff
29.12.2022 11:32
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace ConsoleApplication4
{
    class Program
    {
        // Дан массив С1, С2, …, С24. В массиве есть два элемента равные 0. Заменить все элементы, стоящие между ними, на единицы
        static void Main(string[] args)
        {
            const int n = 24; // Размер массива
            int[] С = new int[n]; // Создали массив
            for (int i = 0; i < n; i++) // Вводим элементы массива
            {
                С[i] = int.Parse(Console.ReadLine());
            }

            bool check = false; // Индикатор замены (пока что выключен)

            for (int i = 0; i < n; i++) // Цикл для выполнения замены
            {
                if (С[i] == 0) // Если проверемый элемент нулевой, то переулючить индикатор замены и закончить текущую иттерацию
                {
                    check = !check;
                    continue;
                }
                if (check == true) // Если индикатор замены включен, то заменяем текущий элемент
                    С[i] = 1;
            }

            for (int i = 0; i < n; i++) // Выводим элементы массива
            {
                Console.WriteLine(С[i]);
            }

            Console.ReadKey(); // Ждем нажатия клавиши
        }
    }
}
0,0(0 оценок)
Ответ:
Мышонок11111
Мышонок11111
20.07.2022 14:20
Код#include <iostream>constexpr double bites_to_megabytes(double a) {    return a / 8388608;}constexpr double megabytes_to_gigabytes(double a) {    return a / 1024;}int main() {    long long a;    short type;    bool is_correct = false;    double answer;    do {        std::cin >> a;        std::cout << "[1] Megabytes \n"                  << "[2] Gigabytes \n"                  << "Convert to [1] or [2]: ";        std::cin >> type;        if (type == 1 or type == 2) {            is_correct = true;        } else {            std::cout << "Meh. Try to type again. \n" << std:: endl;        }    } while (!is_correct);    switch (type) {        case 1:            answer = bites_to_megabytes(a);            break;        case 2:            answer = megabytes_to_gigabytes(bites_to_megabytes(a));            break;    }    std::cout << "An answer of conversion is " << answer << std::endl;    return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота