В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
djsxv
djsxv
25.04.2023 10:36 •  Информатика

Написать программу, решающую : вася имеет х рублей на карманные расходы. сколько банок газировки он сможет купить, если газировка стоит y рублей.

Показать ответ
Ответ:
NastyaKoryak
NastyaKoryak
11.10.2020 03:53

var money, price, count: integer;

begin

 writeln('Введите количество денег и стоимость одной газировки');

 readln(money, price);

 count := 0;

 if(money >= price) then begin repeat

   money := money - price;

   inc(count, 1);

 until money < price;  

 writeln('Петя может купить ', count, ' банок газировки');

 end else writeln('Вася не может купить газировку.');

end.

Объяснение:

1) Создаём переменные

money - количество денег у Васи.

price - цена одной газировки.

count - количество банок после покупки.

2) Запрашиваем сумму денег Васи.

3) Проверяем количество денег, если у Васи денег меньше чем цена одной газировки, то говорим пользователю, что Вася не может купить газировку.

4) Через цикл получаем количество банок и выводим ответ.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота