Написать программу решения на языке паскаль: а)известно, что х кг шоколадных конфет стоит а рублей, а y кг ирисок стоит в рублей. определить, сколько стоит 1 кг шоколадных конфет, 1 кг ирисок, а также во сколько раз шоколадные конфеты дороже ирисок. б)дана длина ребра куба а. найти его объем и площадь поверхности
// а Y кг ирисок стоит В рублей. Определить, сколько стоит 1 кг
// шоколадных конфет, 1 кг ирисок, а также во сколько раз шоколадные конфеты дороже ирисок.
var x,y,a,b: real;
begin
writeln('Введите массу шоколадных конфет');
readln (x);
writeln('Введите сумму потраченную на покупку шоколадных конфет');
readln (a);
writeln('Введите массу ирисок');
readln (y);
writeln('Введите сумму потраченную на покупку ирисок');
readln (b);
writeln ('килограмм шоколадных конфет стоит ',(a/x):0:2,' рублей');//(a/x):0:2 - округряем до сотых)
writeln ('килограмм ирисок стоит ',(b/y):0:2,' рублей');
Writeln ('Шоколадные конфеты дороже ирисок в ',(a/x)/(b/y):0:1,' раз');// - округляем результат до десятых
end.
//Дана длина ребра куба а. Найти его объем и площадь поверхности
Var a: real;
begin
writeln ('введите длину ребра куба');
readln (a);
while a<0 do
begin
writeln ('вы ввели не допустимое значение попробуйте еще раз');
writeln ('введите длину ребра куба');
readln (a);
end;
writeln ('площадь куба равна ',a*a*6);
writeln ('объем куба равен ',a*a*a);
end.