В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу решения ребуса: КУБ=(К + У + Б)^3 . При решении ребусов
одинаковым буквам соответствуют одинаковые цифры.
паскаль

Показать ответ
Ответ:
dashapeit12
dashapeit12
16.08.2021 09:28

1. (A+B+C)&(неA&B&неC)= A&неA&B&неC+B&неA&B&неC+C&неA&B&неC=0+неA&B&неC+0=неA&B&неC

2. (A+B)&(неB+A)&(неC+B)=(A&неB+A&A+B&неB+B&A)&(неC+B)= (A&неB+A+0+B&A)&(неC+B)= (A&неB+A+B&A)&(неC+B)=A&неB&неC+A&неB&B+A&неC+A&B+B&A&неC+B&A*B= A&неB&неC+0+A&неC+B&A&неC+A&B+A&B=A&неB&неC+A&неC+B&A&неC+A&B=A&неC(B+1)+ A&B&(неC+1)=A&неC+A&B= A&(неC+B)

3. (1+(A+B))+((A+C)&1)=1+((A+C)&1)= 1+(A&1+c&1)= 1+A+C=1

4. (A&B&неC)+(A&B&C)+не(A+B)= (A&B&неC)+(A&B&C)+неA&неB= (A&B)&(неC+C)+неA&неB=A&B+неA&неB= A~B

5. (A+B+C)&не(A+неB+C)= (A+B+C)&неA&B&неC=A&неA&B&неC+B&неA&B&неC+C&неA&B&неC=0+неA&B&неC+0=неA&B&неC

0,0(0 оценок)
Ответ:
orlovs2017
orlovs2017
18.07.2020 05:57

1)

var a,b,c,d:real;

begin

  read(a,b);

  c:=(a+b)/2;

  d:=2*a*b;

  if a>b then begin

   a:=d;

   b:=c;

  end;

  if a<b then begin

  a:=c;

  b:=d;

  end;

  writeln(a,' ',b);

end.

 

2)

var a,b:integer;

begin

  read(a,b);

  if (a<1) or (a>31) then writeln(' день введен неправильно');

  if (b<1) or (b>12) then writeln(' месяц введен неправильно');

end.

 

3)

var a,b,c:real;

begin

  read(a,b,c);

  if (a>b)and(a>c)then writeln(a); 

  if (b>a)and(b>c)then writeln(b);

  if (c>b)and(c>a)then writeln(c);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота