В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Arina12345678901
Arina12345678901
10.01.2020 09:59 •  Информатика

Написать программу решения следующей задачи: Определить, какая из
точек A(x1,y1,z1) или B(x2,y2,z2) расположена ближе к точке C(x3,y3,z3). Код нужно написать на языке нужно

Показать ответ
Ответ:
0987mnbv
0987mnbv
20.12.2022 14:36
// PascalABC.NET 3.0, сборка 1076
begin
  var n:=ReadInteger('Число элементов массива=');
  var a:=ArrRandom(n,-25,25);
  Write('Исходный массив: '); a.Println;
  var k:=a.Where(x->sqr(x)>sqr(a[0])).Count;
  if k>0 then Writeln
    ('Найдено ',k,' элементов, квадрат которых больше квадрата первого')
  else Writeln
    ('Нет ни одного элемента, квадрат которого больше квадрата первого')
end.

Тестовое решение:
Число элементов массива=15
Исходный массив: 11 12 -11 -3 -16 -22 22 4 -4 -1 -16 -9 -19 4 16
Найдено 7 элементов, квадрат которых больше квадрата первого
0,0(0 оценок)
Ответ:
ayer1
ayer1
26.11.2022 21:01

Основные - это те без которых он не будет работать?:

монитор - отображение видеоинформации

видеокарта - обработка и подача видеосигнала на монитор

клавиатура и мышь - ввод информации от пользователя

блок питания - распределение питания между внутренними устройствами

жёсткий диск - постоянная память компьютера

оперативная память - временная память компьютера

процессор - основные вычислительные операции

материнская плата - связыает все элементы между собой

куллер - охлаждает

системный блок - для крепления внутренних элементов

дополнительные устройства ввода: сд или двд приводы, сканер, тачпад на ноутах, сенсорные понели, вэбкамеры, микрофоны...

дополнительные устройства вывода: колонки или наушники + звуковая карта, принтеры, плоттеры, проэкторы..

устройства для коммуникаций и сетей: модемы, сетевые карты, блютус/ик платы или стационарные устройства..

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота