В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lykuanenkoartem
lykuanenkoartem
05.02.2020 23:50 •  Информатика

Написать программу с постусловием)с#
1. для десяти выстрелов, координаты которых с клавиатуры, вывести тестовые сообщения и попадании в мишень.
2. составить программу, которая определяет сумму s и количество k целых чисел лежащих на заданном отрезке [a; b]. границы отрезка целые числа.
3. реализовать консольное меню с циклы do-while. выбор пунктов осуществляется вводом номера через клавиатуру. выбрав первый пункт меню, выводится ваше имя и возврат в меню, второй пункт – фамилия и возврат в меню, третий пункт – группа и возврат в меню, четвертый – выход из программы.
4. осуществить вывод в цикле построчно на экран чисел от n-5 до n+5, где n номер варианта. в теле цикла сначала реализовать проверку значения на равенство варианту (использовать условный оператор if) и в случае истинного результата выполнить оператор continue, а затем осуществить вывод на экран текущего значения.
5. реализовать тот же цикл что и в предыдущем , но вместо оператора continue использовать оператор break. проанализировать отличия в данных операторах.

Показать ответ
Ответ:
svetasvetlana7
svetasvetlana7
08.02.2020 07:18
1. Поименованная информация, хранящаяся в долговременной памяти компьютера:
1) файл

2. Расширение файла указывает:
2) на тип данных, хранящихся в нем

З. Определите тип файла выход.ррt.
4) презентация

4. Какое расширение имеют текстовые файлы?
2) rtf, doc, docx, txt

5. Заполните пропуск в предложении
Полное имя файла включает в себя ... и имя файла.
ответ: путь

6. Установите соответствие.

Расширение Тип файла
1) .wav В) звуковой
2) .bmp Б) графический
3) .zip А) архив

7. Файловая система — это:
3) структура для хранения файлов и каталогов

8. Объект, не являющийся элементом файловой системы:
3) корзина

9. Полное имя файла D:\8 класс\Иванов Иван\Контрольная pa6oтa\контрошa.doc. В какой папке хранится файл контрошa.doc?
3) Контрольная работа

10. В каталоге хранился файл Отметки.txt. После создания в этом каталоге подкаталога и перемещения в созданный подкаталог файла Oтметки.txt полное имя файла стало A:\SCHOOL\USER\TXT\MARCH\Oтметки.txt. Полное имя каталога, в котором хранился файл до пере¬мещения:
2) A:\SCHOOL\USER\TXT

11. Что представляет собой каталог диска в одноуровне¬вой файловой системе?
ответ:линейная последовательность

12. Что такое корневой каталог?
ответ:начальный каталог в структуре каталогов устройства внешней памяти, в котором могут храниться файлы и другие подкаталоги.
0,0(0 оценок)
Ответ:
дстмсдрлпоа
дстмсдрлпоа
19.06.2021 12:56
Чтобы прервать ввод в массив нужно ввести число "-1010".
class ArrayNegative{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in); long eArray[] = new long[1];
  while((eArray[eArray.length-1] = in.nextLong())!=-1010){
   long nArray[] = new long[eArray.length+1];
   for(int nCell = 0; nCell<eArray.length; nCell++)nArray[nCell]=eArray[nCell];
   eArray = nArray;
  } eArrayCell:
  for(int cCell = 0; cCell<eArray.length-1; cCell++){
   if(eArray[cCell]>0)continue;
   else for(int eCell = cCell+1; eCell<eArray.length-1; eCell++)
   if(eArray[eCell]>0){
    eArray[eArray.length-1]=eArray[cCell];
    eArray[cCell]=eArray[eCell];
    eArray[eCell]=eArray[eArray.length-1];
    continue eArrayCell;
   }
   break;
  }
  for(int cCell = 0; cCell<eArray.length-1; cCell++)System.out.print(eArray[cCell]+" ");
 }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота